Android System Requirements

The following list includes the required components to run Jobulator Mobile on Android-powered devices.

Android 2.2 (Froyo) or higher

  • Please note, many manufactures and carriers have allowed Android 2.1 users to update to 2.2 and even higher. Please check your phone settings for an available update or contact your manufacturer/carrier regarding the availability of an update.

Touch Screen

Was this article helpful?
5 out of 17 found this helpful
Have more questions? Submit a request