Apple System Requirements

With all the updates that Apple makes each year with their new devices and their new operating systems (OS), it can be hard to know if your device will be able to use Jobulator. To provide clarity, the current version of Jobulator can be supported by all Apple devices that have iOS 7, iOS 8, iOS 9, and iOS 10 on them. If you device has a prior version like iOS 6, you would not be able to download Jobulator to that device.

These devices can support either iOS8, iOS9, and iOS10:

  • iPhone 4, 4S, 5, 5C, 5S, 6, 6Plus, SE, 7, 7Plus
  • iPad 2, 3, 4, Air, iPad mini, iPad Pro
  • iTouch 5th generation 
Was this article helpful?
17 out of 25 found this helpful
Have more questions? Submit a request